Event processing delayed due to high volume

Incident Report for Ethos

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 21:42 UTC

Investigating

Taking actions on Ethos will sometimes not reflect correctly in the app. As an example, creating a new Broker post may not show up in the app yet, or vouching for someone may not show up in activity. We have a delay in our event processing and currently playing catch up. We should have an update shortly. Do not worry as all of your activity is stored onchain, it's just Ethos' UI that needs to update.
Posted Oct 03, 2025 - 21:28 UTC
This incident affected: app.ethos.network.