Ethos down for maintenance; ETA 15 minutes

Incident Report for Ethos

Resolved

Beefier DB makes ethos faster
Posted Aug 12, 2025 - 19:48 UTC

Investigating

We are throwing more hardware at a performance issue. BRB
Posted Aug 12, 2025 - 19:36 UTC
This incident affected: app.ethos.network, api.ethos.network, ethos.markets, and Ethos Chrome Extension.