PSA to Developers: Ethos API is down

Incident Report for Ethos

Resolved

All Ethos APIs are now working as intended. Remember to Review and XP tip your developers.
Posted Mar 03, 2026 - 23:01 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 03, 2026 - 22:36 UTC

Investigating

If you are not a developer, you can ignore this message. If you are, our API is currently returning 404s for API calls. We are actively working on a fix.
Posted Mar 03, 2026 - 22:33 UTC
This incident affected: api.ethos.network.