Systems are back online. Monitoring for stability.
Posted Oct 20, 2025 - 21:02 UTC
Investigating
Due to the upstream AWS outage, several service providers that Ethos relies on are failing. Users are not able to sponsor their transactions, and some users are having issues logging in with privy. Other parts of the product like the API, score retrieval, and chrome extension are all working as intended.
Posted Oct 20, 2025 - 14:58 UTC
This incident affected: app.ethos.network and ethos.markets.