Privy claims that the incident has been resolved. We see all the systems have been restored.
Posted Oct 14, 2025 - 15:13 UTC
Monitoring
Privy has restored services and is currently monitoring the situation.
Login and wallet connection functionality should now be working normally on our side as well. We’re keeping this incident in Monitoring until Privy confirms full stability.
Posted Oct 14, 2025 - 14:04 UTC
Identified
We’re affected by a Privy service outage, which impacts login, wallet connection, and actions requiring authentication. We’re monitoring Privy’s status and will update as soon as it’s resolved.