Ethos Profiles not loading

Incident Report for Ethos

Resolved

Profiles are now loading again.
Posted Jul 17, 2025 - 18:42 UTC

Identified

We are deploying a fix now. ETA 5 minutes.
Posted Jul 17, 2025 - 18:42 UTC
This incident affected: app.ethos.network and api.ethos.network.