Feed/Home page down

Incident Report for Ethos

Resolved

Refreshing the cache worked!
Posted Nov 06, 2025 - 23:29 UTC

Identified

Due to an API change that still had stale data cached, the Ethos home page is not loading. It will be back in under 10 minute when the cache expires. We are attempting to force a refresh now.
Posted Nov 06, 2025 - 23:28 UTC
This incident affected: app.ethos.network.