Degraded Performance

Incident Report for Ethos

Resolved

Performance stable and search are fully operational.
Posted Jun 19, 2026 - 17:44 UTC

Monitoring

Search functionality restored, performance solid. Continuing to monitor.
Posted Jun 19, 2026 - 17:05 UTC

Update

Site performance restored; we've purposefully disabled search until we can further optimize it to handle current load.
Posted Jun 19, 2026 - 16:48 UTC

Investigating

Performance is degraded while we investigate API driven database load.
Posted Jun 19, 2026 - 15:44 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 19, 2026 - 15:00 UTC

Monitoring

It appears an aggressive 3rd party tipped us over a threshold that degraded performance for everyone. A fix has been implemented. We are monitoring the situation to be sure that the fix will hold. Will update once we are confidently resolved.
Posted Jun 19, 2026 - 14:59 UTC

Update

Continuing to investigate root cause of degraded performance. Will update again in 1 hour or sooner as investigation unfolds.
Posted Jun 19, 2026 - 13:44 UTC

Investigating

We are currently investigating degraded performance of the Ethos website and API. Watch for updates.
Posted Jun 19, 2026 - 12:52 UTC
This incident affected: app.ethos.network, api.ethos.network, ethos.markets, and Ethos Chrome Extension.