Down for maintenance

Incident Report for Ethos

Resolved

Maintenance complete! Ethos is fully operational.
Posted Nov 08, 2025 - 03:34 UTC

Investigating

Ethos will be down for quick DB maintenance. Should be back up within 5 minutes. Please hodl tight.
Posted Nov 08, 2025 - 03:32 UTC
This incident affected: app.ethos.network and api.ethos.network.