Ethos profile pages currently not working in-app

Incident Report for Ethos

Resolved

All profile pages are now loading. Please enjoy.
Posted Jun 30, 2025 - 18:30 UTC

Investigating

Our app is currently crashing when going to look at a user's profile page. We're working on a fix
Posted Jun 30, 2025 - 18:07 UTC
This incident affected: app.ethos.network.